Minor issue on Region VD

Minor incident Region VD
13-07-2023 02:26 CEST · 18 minutes

Updates

Update

Internet provider announces that connection is back.

July 13, 2023 · 02:45 CEST
Issue

Our internet provider got an small outage, which caused the unavailability of the systems.

July 13, 2023 · 02:26 CEST

← Back