Minor issue on Region VD

Minor incident Region VD
2022-09-23 08:17 CEST · 2 minutes

Updates

Resolved

The incident is now closed.

September 23, 2022 · 08:20 CEST
Issue

We are experiencing a minor issue on our region VD. We are investigating to recover the normal services as soon as possible

September 23, 2022 · 08:17 CEST

← Back