Minor issue on Region VD

Minor incident Region VD
2022-07-15 01:14 CEST · 1 minute

Updates

Resolved

The incident is now closed.

July 15, 2022 · 01:16 CEST
Issue

We are experiencing a minor issue on our region VD. We are investigating to recover the normal services as soon as possible

July 15, 2022 · 01:14 CEST

← Back