Network incident — BGP routing degradation

Minor incident Region GE Region VD Network
27-04-2026 12:03 CEST · 4 hours, 19 minutes

Updates

Resolved

The intermittent slowdowns and connectivity impact caused by the BGP routing issue on our core routers have been mitigated, and services are now stable.

Our team is continuing to investigate the underlying root cause to ensure this class of incident cannot recur.

April 27, 2026 · 13:22 CEST
Issue

Some services are experiencing intermittent slowdowns with possible latency and connectivity impact, caused by a BGP routing issue on our core routers degrading network performance. Our team is actively investigating and working on a resolution.

April 27, 2026 · 12:03 CEST

← Back