Minor issue on Region VD
Minor incident
Region VD
27-12-2025 00:25 CET
· 39 seconds
Updates
Update
December 27, 2025 · 02:06 CET
A network outage occurred in the VD region following scheduled maintenance on December 26th at 10:00 PM.
Issue
December 27, 2025 · 00:25 CET
We are experiencing a minor issue on our region VD. We are investigating to recover the normal services as soon as possible
← Back
Hidora Status Page