Minor issue on Region GE

Minor incident Region GE
20-10-2025 11:35 CEST · 39 seconds

Updates

Resolved

The incident is now closed.

October 20, 2025 · 11:35 CEST
Issue

We are experiencing a minor issue on our region GE. We are investigating to recover the normal services as soon as possible

October 20, 2025 · 11:35 CEST

← Back