Minor issue on Region GE

Minor incident Region GE
20-09-2025 19:21 CEST · 2 minutes, 1 second

Updates

Resolved

The incident is now closed.

September 20, 2025 · 19:23 CEST
Issue

We are experiencing a minor issue on our region GE. We are investigating to recover the normal services as soon as possible

September 20, 2025 · 19:21 CEST

← Back