Minor issue on Region GE

Minor incident Region GE
08-03-2025 12:28 CET · 1 hour, 7 minutes

Updates

Resolved

The incident is now closed.

March 8, 2025 · 13:36 CET
Issue

We are experiencing a minor issue on our region GE. We are investigating to recover the normal services as soon as possible

March 8, 2025 · 12:29 CET

← Back