Minor issue on Region GE

Minor incident Region GE
17-09-2024 19:15 CEST · 12 minutes

Updates

Resolved

The incident is now closed.

September 17, 2024 · 19:27 CEST
Issue

We are experiencing a minor issue on our region GE. We are investigating to recover the normal services as soon as possible

September 17, 2024 · 19:15 CEST

← Back