Network issue

Minor incident Region GE Region VD Network
25-04-2024 06:26 CEST · 19 minutes

Updates

Resolved

All good.

April 25, 2024 · 06:45 CEST
Investigating

All seems to be good now. We are near the end. Sorry for inconvenience

April 25, 2024 · 06:26 CEST

← Back