Minor issue on Region VD
      
Minor incident
      
        Region VD
    
    
      
25-04-2024 05:24 CEST
      
      · 46 minutes
    
  Updates
          Investigating
        
        
April 25, 2024 · 05:33 CEST
        
      
      We are working on it. It’s a routage issue due to the router change on ISP side. We will keep you informed
          Issue
        
        
April 25, 2024 · 05:24 CEST
        
      
  We are experiencing a minor issue on our region VD. We are investigating to recover the normal services as soon as possible
← Back
 Hidora Status Page
            
Hidora Status Page