Minor issue on Region GE

Minor incident Region GE
08-04-2024 16:46 CEST · 3 minutes

Updates

Resolved

The incident is now closed.

April 8, 2024 · 16:50 CEST
Issue

We are experiencing a minor issue on our region GE. We are investigating to recover the normal services as soon as possible

April 8, 2024 · 16:46 CEST

← Back