Minor issue on Region GE

Minor incident Region GE
25-03-2024 02:14 CEST · 1 minute

Updates

Resolved

The incident is now closed.

March 25, 2024 · 02:16 CEST
Issue

We are experiencing a minor issue on our region GE. We are investigating to recover the normal services as soon as possible

March 25, 2024 · 02:14 CEST

← Back