Minor issue on Region VD

Minor incident Region VD
19-11-2023 16:42 CEST · 1 minute

Updates

Resolved

The incident is now closed.

November 19, 2023 · 16:44 CEST
Issue

We are experiencing a minor issue on our region VD. We are investigating to recover the normal services as soon as possible

November 19, 2023 · 16:42 CEST

← Back