Minor issue on Region GE

Minor incident Region GE
15-11-2023 10:35 CEST · 4 minutes

Updates

Resolved

The incident is now closed.

November 15, 2023 · 10:39 CEST
Issue

We are experiencing a minor issue on our region GE. We are investigating to recover the normal services as soon as possible

November 15, 2023 · 10:35 CEST

← Back