Minor issue on Region GE

Minor incident Region GE
05-11-2023 08:18 CEST · 2 minutes

Updates

Resolved

The incident is now closed.

November 5, 2023 · 08:20 CEST
Issue

We are experiencing a minor issue on our region GE. We are investigating to recover the normal services as soon as possible

November 5, 2023 · 08:18 CEST

← Back